Herramienta de diagnóstico de DirectX

La documentación de la Herramienta de diagnóstico de Microsoft® DirectX® incluye los siguientes temas:

  • Acerca de la Herramienta de diagnóstico de DirectX
  • Qué debe buscar
  • Probar los componentes de DirectX
  • Reemplazar el comportamiento predeterminado


Acerca de la Herramienta de diagnóstico de DirectX

La herramienta de diagnóstico de Microsoft® DirectX® proporciona información acerca de los componentes y controladores de la interfaz de programación de aplicaciones (API) DirectX que están instalados en el sistema. Permite realizar pruebas de salida de sonido y gráficos, y de los proveedores de servicios de Microsoft DirectPlay®. También permite deshabilitar algunas características de aceleración de hardware.

Puede utilizar la herramienta de diagnóstico para recopilar la información que le solicite el técnico durante una llamada al servicio de soporte técnico, y puede guardar dicha información, copiarla y pegarla en un mensaje de correo electrónico.

La información se presenta en varias páginas. Para pasar de una página a otra, puede utilizar cualquiera de los métodos siguientes:

  • Haga clic en las fichas.
  • Haga clic en el botón Página siguiente.
  • Presione las teclas FLECHA IZQUIERDA o FLECHA DERECHA cuando el enfoque se encuentre en una ficha.

Puede especificar cómo desea que esta herramienta muestre las tablas. Para ello, elija la columna por la que desea ordenar las filas de la tabla. Haga clic en el botón del encabezado en la parte superior de la columna; la tabla se ordenará en orden alfabético o numérico según los elementos de la misma. Para invertir el orden, haga clic de nuevo en el botón del encabezado.

También puede hacer clic en el botón Guardar toda la información para guardar todos los datos en un archivo de texto.

Nota

  • Determinada información, como la cantidad de memoria instalada en una tarjeta gráfica, puede ser aproximada.


Qué debe buscar

Si tiene algún problema al ejecutar aplicaciones que utilicen Microsoft® DirectX®, la Herramienta de diagnóstico de DirectX puede ayudarle a encontrar el origen del problema. Éstos son algunos de los síntomas que debe buscar:

  • Versiones incorrectas de los componentes de DirectX. En la sección Notas de la página Archivos de DirectX, busque advertencias acerca de versiones beta y archivos de depuración. Los archivos de versiones beta son versiones de prueba preliminares y no se deben instalar con aplicaciones comerciales. Igualmente, las versiones de depuración, que se utilizan durante el desarrollo del programa, no se deben instalar con el producto final y pueden hacer que las aplicaciones se ejecuten mucho más lentamente que con las versiones comerciales de los componentes.
  • Ausencia de aceleración de hardware. Algunos programas se ejecutan muy despacio, e incluso no funcionan, si no está disponible la aceleración de hardware de Microsoft DirectDraw® o de Direct3D®. En la página Pantalla, compruebe en la sección Características de DirectX si DirectDraw, Direct3D o la aceleración de Texturas AGP están marcadas como "No disponible". En ese caso, tenga en cuenta la posibilidad de actualizar el hardware.
  • El dispositivo no está conectado. Si un joystick u otro dispositivo de entrada no responde, es posible que no esté correctamente configurado. Asegúrese de que el dispositivo aparece en la página Entrada de la Herramienta de diagnóstico de DirectX. De lo contrario, utilice el Panel de control para agregar el dispositivo.
  • Controladores sin firmar. Microsoft no ha comprobado la compatibilidad con la versión más reciente de DirectX de los controladores sin firmar. Estos controladores aparecen en la página del componente correspondiente.

Nota: Si utiliza Servicios de Terminal Server para trabajar en un sistema remoto que admite aceleración de hardware, la Herramienta de diagnóstico de DirectX podría indicar compatibilidad con la aceleración de hardware. Sin embargo, los Servicios de Terminal Server no pueden utilizar aceleración de hardware y, por lo tanto, la compatibilidad no está disponible.


Probar los componentes de DirectX

Puede probar Microsoft® DirectDraw® y Direct3D® en cada monitor conectado al sistema. También puede probar DirectSound® en cada dispositivo de salida de ondas y DirectMusic® en cada puerto de música.

Para probar una función de DirectX: haga clic en el botón Probar de la página correspondiente, lea los mensajes que aparezcan y observe o escuche las pruebas. Deje que se ejecute cada prueba hasta que aparezca un mensaje preguntando si se realizó correctamente. Si responde No, no se ejecutarán más pruebas.

Para DirectMusic sólo existe una prueba. Haga clic en Aceptar cuando compruebe si la música se reproduce correcta o incorrectamente.

Puede probar las funciones de Microsoft DirectPlay® en cualquiera de los proveedores de servicios disponibles.

Para probar DirectPlay

  1. En la página Red, haga clic en Probar DirectPlay. En el cuadro de diálogo Probar DirectPlay, escriba un nombre de usuario y elija un proveedor de servicios. Seleccione Crear nueva sesión y haga clic en Aceptar. Si eligió una conexión mediante módem, haga clic en Contestar en el cuadro de diálogo Conexión del módem para poner el módem en modo de respuesta automática.
  2. A continuación, ejecute la Herramienta de diagnóstico de Microsoft DirectX® en otro equipo que pueda establecer con el primero la conexión seleccionada. Haga clic en Probar DirectPlay, escriba un nombre de usuario diferente, elija el mismo proveedor de servicios, haga clic en el botón Unirse a sesión existente y haga clic en Aceptar.

    En algunos tipos de conexión, es posible que se le pida más información, como un número de teléfono. Si utiliza una conexión TCP/IP en una red local puede dejar en blanco el cuadro de texto.

  3. En el segundo equipo, en la Lista de sesiones que contiene el nombre de la sesión que creó en el primer equipo, seleccione el nombre de la sesión y haga clic en Aceptar.
  4. Ambos equipos deben mostrar a continuación un cuadro de diálogo de charla. Escriba un mensaje en el cuadro de entrada de uno de los equipos y haga clic en Enviar. El mensaje debe aparecer en el área de desplazamiento del cuadro de diálogo de charla, en ambos equipos.


Reemplazar el comportamiento predeterminado

En la página Sonido puede mover el control deslizante para establecer un nivel diferente de aceleración de hardware. El nivel que establezca permanecerá vigente después de cerrar la Herramienta de diagnóstico de Microsoft® DirectX®.

Si está disponible la aceleración de hardware para Microsoft DirectDraw® o Direct3D®, puede deshabilitarla si lo desea. Para ello, vaya a la página Pantalla de cada dispositivo de pantalla y haga clic en el botón Deshabilitar. Después de deshabilitar la aceleración de hardware, no estará disponible en ninguna aplicación, incluso después de cerrar la Herramienta de diagnóstico de DirectX. Para volver a habilitar la aceleración de hardware, haga clic en el botón Habilitar de la página Pantalla correspondiente.

Nota

  • Al deshabilitar la aceleración de DirectDraw también se deshabilita la aceleración para Direct3D.

También puede reemplazar la frecuencia de actualización del monitor establecida para las aplicaciones DirectDraw que se ejecutan a pantalla completa. Sólo debe hacerlo si tiene algún problema de presentación con una aplicación y tiene un buen motivo para creer que la aplicación está utilizando una frecuencia de actualización no válida.

Para reemplazar una frecuencia de actualización

  1. En la página Más ayuda, haga clic en el botón Reemplazar.
  2. En el cuadro de diálogo Suplantar comportamiento de actualización de DirectDraw, seleccione el cuadro de edición y escriba una frecuencia de actualización válida para el monitor.

    El botón de opción Reemplazar valor se seleccionará automáticamente al hacerlo.

  3. Haga clic en Aceptar.

Para cancelar el reemplazo de la frecuencia de actualización y permitir que las aplicaciones DirectDraw establezcan su propia frecuencia

  1. En la página Más ayuda, haga clic en el botón Reemplazar.
  2. En el cuadro de diálogo Suplantar comportamiento de actualización de DirectDraw, haga clic en el botón de opción Predeterminado y haga clic en Aceptar.